HTTP 404 for http://localhost:5380/ws/dictionaries/0.11c


I’m trying to run dcc-release, and as part of the initialization it requests HTTP GET on http://localhost:5380/ws/dictionaries/0.11c. I have the dcc-submission-service setup, but it is returning a 404 on this URL.

There’s no error reported in the dcc-submission-server log. It just says “DEBUG o.i.d.s.s.w.c.DictionaryController - Getting dictionary: 0.11c”. I’m running dcc-submission-server-4.3.6-SNAPSHOT, and dcc-release-client-4.2.5-SNAPSHOT.jar.

Is there some data I need to load in the dcc-submission-server to satisfy the dictionary request?

Brian K.

Perhaps you should point to the latest production dictionary:

This would be much simpler. Is the Submission System required?

Thanks, that worked. I edited application.yml and re-built the application to use, and that got me passed the dictionary lookup. I tried replacing the application.yml by specifying a -classpath on the command line, but the spring application context didn’t pick it up. Now, I need to handle the mail server:

org.springframework.mail.MailSendException: Mail server connection failed; nested exception is javax.mail.MessagingException: Could not connect to SMTP host: localhost, port: 25;
nested exception is: Connection refused. Failed messages: javax.mail.MessagingException: Could not connect to SMTP host: localhost, port: 25;

mail.enabled: false should fix that

Bob, I think mail.enabled is ignored. There is a MailProperties dependency injected in org.icgc.dcc.release.client.mail.Mailer, but the only use is for mail.getRecipients(). There is no enabled property check in the org.springframework.mail.javamail.JavaMailSenderImpl class.

I commented out the mail send, and the ANNOTATE task completed succesfully. On to the next thing.

Brian K.

This should work:

  public Boolean isEnabled() {
    return properties.getMail().getEnabled();